Answered By: Kathryn Park
Last Updated: Jul 28, 2015     Views: 72

Yes. Generally you'll need the latest browser, fairly current operating system, javascript and cookies enabled in tour browser and Adobe Reader to read PDF articles and eBooks. See the Minimum Browser Requirements for EBSCO Interfaces link (below) for more details.

Answers by Topic

Ask COM Library Home

Your Questions Answered

Your Questions Answered!

Get more on:

Ask Us!

Look for the Ask Us! button to ask your research question!

Select the Ask Us button on the top right corner of any page to ask real COM Library staff a question via live chat during library hours.

More Ways To Ask